Login to download the latest version of Mint and your favorite Pepper, purchase additional licenses, or post in the Forum. Don't have an account? Create one!

In Partnership with Media Temple

Mint Forum

Download Counter pepper not working in Mint 2.0?

stormy
Minted
Posted on Feb 01, '07 at 08:30 pm

I am a new Mint user. I am very interested in tracking downloads, so I added the Download Counter pepper: http://orderedlist.com/articles/pepper-download-counter

Unfortunately, it’s not tracking anything. Do you know if it’s compatible with Mint 2.0? Any other hints?

Sam Brown
Third-Party Pepper Developer
Posted on Feb 02, '07 at 02:44 am

HI stormy, I can confirm it isn’t working here either. However, this is an issue for the Pepper Developer. Need to contact Steve about this.

I can also confirm it is not working. Has anyone heard from Steve on this?

Ronald Heft
Third-Party Pepper Developer
Posted on Feb 20, '07 at 08:14 pm

I haven’t heard anything about that particular Pepper, but I do know another one is in the works. The new Pepper will support the Javascript method, .htaccess, and URL redirct; basically all the previous Mint 1.x methods in one Pepper. It hopefully won’t be too long until a release.

orderedlist
Third-Party Pepper Developer
Posted on Apr 21, '07 at 10:10 pm

Greetings folks. I know I’m way late to this party, but the Pepper has been updated, and is available at http://orderedlist.com/articles/pepper-download-counter Let me know if it’s still not working for you. Thanks.

m00dawg
Minted
Posted on May 06, '07 at 07:25 pm

Still not working. Here is the problem:

    if ($is_download) {
        $_GET['is_download'] = 1;
        echo 'Made it in';
        $prefs = $this->prefs;
        $ext_array = explode(',',$prefs['fileExtensions']);

The echo statement was being sent prior to the rest of the page-headers, which was causing it to break. Commenting out the echo statement fixed things up. This, by the way, was in class.php.

Hope that helps!

Beesign
Minted
Posted on Oct 25, '07 at 10:15 am

Thanks for that! I had the same problem on my site (downloading didn’t work, got the “echo” messages before download occured.

Martin Vereecken bizzybee.be

You must be logged in to reply. Login above or create an account