Login to download the latest version of Mint and your favorite Pepper, purchase additional licenses, or post in the Forum. Don't have an account? Create one!

In Partnership with Media Temple

Mint Forum

Configuring Mint for WordPress

Thanks, I saw that you had posted that before but I wasn’t sure how to disbale mod_rewrite.

No dice…I moved my Mint directory to root and uploaded the .htaccess file, but I’m still getting my 404 page when I go to ronpaulchronicles.com/mint.

I still can’t install Mint…now when I go to ronpaulchonicles.com/mint I get a blank page.

jarjac
Minted
Posted on Mar 21, '08 at 10:09 pm

I’m a bit confused. I’ve yet to have a single serious problem with any of the various things installed and updated on my server, that is until dealing with Mint.

I currently see my site layout with a 404 error.

I’ve edited db.php. My wp-config.php file doesn’t list ‘localhost’ but instead a PHP function. Should I change it to the PHP function or should I keep it as localhost?

I’ve installed the mint directory to root.

I’ve added a .htaccess file to the mint directory that reads as follows:

BEGIN WordPress

RewriteEngine off

END WordPress

I navigated to MYDOMAINNAME.com/mint, and it shows the 404 error.

Where am I going wrong?

jarjac
Minted
Posted on Mar 21, '08 at 10:18 pm

I don’t know markdown well enough to get the entire .htaccess file to post, but its the same as Shaun’s previous post.

I am sure my problem is that I am tired, 10:44pm here, but I do not think my stats are working. Just upgraded to 2.15 from version 1. I changed to another domain, pbaphotography.com. I see the code in my word press header, but when I go to a proxy site to visit my own site from another IP, I do not see any stats. What am I missing? I am sure it is something simple, since I did not have a problem with my old domain. Can someone checkout, pbaphotography.com for me? Perhaps sleep will help ;)

Thanks, Paul

Ignore my previous post. I show one hit around 2am. Using Firefox. Not me. Guess all is well. Thanks, Paul

I installed mint on my site which is powered by wordpress and I only see a blank page when I go to addlocal.com/mint (I used my wordpress database setting in mint’s db.php file) I also tried wp-mint nothing seems to work any other suggestions?

Shaun Inman
Mint/Pepper Developer
Posted on Jun 23, '08 at 09:35 am

Try uninstalling/reinstalling (including uploading a fresh copy of the Mint directory). Somehow the Default Pepper wasn’t installed (which should be possible). Make sure all files are completely uploaded via FTP before beginning the installation.

Nice info. The plugin works fine in WP 2.6.

I really need this Mint! So I have

done a successful compatibility test

uploaded all folders and files

uploaded the WP-Mint plugin

activated the plugin

amended the db.php

amended the index.php

created a .htaccess with the two recommended pieces of code

re-uploaded the files

and when I enter mydomain.com/mint I still get :

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

HELP….!!!!! What must I do? Any help/suggestions to correct the situation will be welcome

Shaun Inman
Mint/Pepper Developer
Posted on Sep 09, '08 at 10:52 am

First, if you are using the WordPress Mint plugin you do not need to use the .htaccess method of adding Mint to yours site; the plugin does this for you.

Next, you are describing a generic internal server error. You will need to ask your host about this specific issue although the most common cause is file permissions.

Word to the wise, don’t send a support email and then post the same issue in the Forum if you still want a response to your email. Given the two options I will always reply in the Forum (so that other’s can benefit) and file the email without replying.

Shaun,

what chmod should Mint be set at?

Have found the posts on CHMOD for WP. I’ll go try 777 and 775

My first attempt has got rid of the 500 Internal error. Now it’s a 404 which I hope will be gone in a few seconds after trying the two csettings above.

Shaun Inman
Mint/Pepper Developer
Posted on Sep 09, '08 at 01:24 pm

Mint doesn’t require any special settings. On my server, its PHP files are the default 644 and folders are the default 755. Your server may have different, non-standard requirements which is why you’ll need to ask your host (or see their documentation).

Thanks Shaun. Will try your setting first.

I have a plugin that provides some additional integration between Mint and Wordpress. http://compu.terlicio.us/code/plugins/mint

~ Christopher

Cyrus Smith
Mint-less
Posted on Oct 21, '08 at 12:43 pm

Works like a charme! Thanks!

[url]=http://mls.fastrealestate.net ]Multi List Service[/url]

marcel
Minted
Posted on Nov 27, '08 at 09:55 am

After all, the WordPress Plugin mentioned on page one seems to be discontinued, jwriteclub, does your plugin also integrate with Bird Feeder?

SebKom
Minted
Posted on Dec 01, '08 at 06:11 pm

What happens if mint is installed in domain.com and our wp blog is installed in sub.domain.com? The plugin doesn’t work, does it?

It should work fine, you simply need to specify that mint is installed at http://domain.com/mint or whatever. While it “guesses” at the auto configuration, you can overwrite this on the “Settings -> uMint” page.

At the moment I don’t have integration for Bird Feeder, although I don’t think it would be difficult to add, if there is any interest.

Also, I updated the plugin recently for 2.7 with nicer, 2.7 compatible widgets.

~ Christopher

marcel
Minted
Posted on Jan 18, '09 at 06:50 am

There is, Christopher. There certainly is. I don’t want my stats in two different places, I want them in Mint. Please! ;)

Right oh,

I’m opening a new feature at the bug tracker http://redmine.paintedrockcommunication … /micromint .

If anyone has any trouble, or wants new features, just go there and add a ticket.

~ Christopher

marcel
Minted
Posted on Jan 21, '09 at 08:20 am

Great. Thanks.

You must be logged in to reply. Login above or create an account