Login to download the latest version of Mint and your favorite Pepper, purchase additional licenses, or post in the Forum. Don't have an account? Create one!

In Partnership with Media Temple

Mint Forum

Crawlers Pepper

Running Movable Type and Crawlers 0.6, I have the php include as the first line after the <body> tag, and it doesn’t seem to be tracking anything. Earlier yesterday, I tried it high in the <header> section, and it also didn’t track anything. (In the header, should I use the code as given [<?php ... ?>] or do I need to alter it to make it <header>-appropriate?)

It’s possible I’m doing something wrong, so I’m curious if anybody else is having the same problem.

Cheers MLS, I look forward to seeing the update.

Good work on the pepper, its looking to be very useful

Now that we have proven a PHP tracker can essentially add data into the system without much problems, does this mean it’s the first step to a non-js tracker tag, or a hybrid one in which we can get more data?

@Culture Snob

I run Mint with Movable Type, including the Crawlers Pepper. I put the php code at the very top of my MT templates, before even the doc type…it seems to be working just fine for me so far.

Posted on Mar 08, '07 at 08:49 pm

I’m a bit worried that the error I mentioned in a previous post will stop search engines from seeing my pages. Therefore I’ve disabled it for the moment.


@That Guy

I’ve now put the code before the header, in the header, and after the header, and I’m not tracking any crawler activity with any of those methods, even though AWStats is recording plenty. If anybody else has had this problem and has figured out a fix, I’d appreciate the help.

Posted on Mar 21, '07 at 07:23 am

I’ve just looking into one error that has been seen on a few sites before I release v1.0.

If you see an error that looks like this:

Fatal error: Call to a member function on a non-object in /*/mint/app/lib/pepper.php on line 56

Please let me know about it, where you see it, and what blog/CMS you are running if any.

So far this problem has only been reported by people running WordPress and I believe it’s the placement of the crawler tracker code that is causing this. I will install WordPress and try to simulate the issue and get a fix out to anyone encountering this problem.

Posted on Mar 21, '07 at 02:14 pm

mls, I’m running WordPress and as stated above, I ran into this error. If you wish to utilise my install to do some tests, let me know.


Posted on Mar 21, '07 at 04:41 pm

This interesting — I haven’t seen the error on my site itself but when I did an ego search for my site on Google, it shows the error as the text of my website. See the cached version here.

GoogleBog hit me about nine days ago, probably around when I started to transition from a TextPattern powered site to one powered by WordPress.

I’ve tinkered with the page since then, but the order of things within the head block should still be the same:



Posted on Mar 21, '07 at 06:54 pm

If you look at my previous post You’ll notice I flagged this up. It’s only present when you try the crawlers view. I’d suggest anyone running WordPress check the crawlers view and disable the pepper until this gets fixed.

As your cached Google page shows, crawlers will see the error message and nothing more.


Posted on Mar 21, '07 at 07:36 pm

Good call, SDJL.

Hopefully this will be fixed soon.

Oh, the order of items my head tags seems to have been formated out of my last post. The order is:

The title tags, then the code Mint requires to track, then the snippet of code Crawler requires and then the closing head tag.


Posted on Mar 23, '07 at 06:28 am


when I use your public beta and put your code in to my pages I get only an error:

Warning: main(/mint/pepper/mlslatest/crawlers/tracker.php): failed to open stream: No such file or directory in ///webseiten/exusudesign/wLayout/structure/head.php on line 9 (that the file where I included your code line)

Fatal error: main(): Failed opening required ‘/mint/pepper/mlslatest/crawlers/tracker.php’ (include_path=’.:/usr/local/lib/php’) in ///webseiten/exusudesign/wLayout/structure/head.php on line 9

What is wrong? Thank you for help Regards from Berlin Mike

Third-Party Pepper Developer
Posted on Mar 23, '07 at 11:08 pm

SDJL, I’m seeing the same thing on my Wordpress install. I have my site in another directory so I had to alter the require line, placed as follows in the header.php file…

and I also get..

Fatal error: Call to a member function on a non-object in /web/site/mint/app/lib/pepper.php on line 56

I’ve removed the require line for now.

I too am interested in this

Whoops, didn’t see the public beta ;)

This is sweet. I’d love to use this as well. I think it would virtually completely my installation.

It would be reeeeeally nice if everyone in this discussion would mention where they’re placing the line of code, so that it adds a little clarity to the mix. Just sayin’.

I have mine in the sidebar, but it really doesn’t matter, since all the bots see are the source code. You can really put it anywhere you want.

Posted on Mar 29, '07 at 09:49 pm

I’ve fixed a few of the errors found and I am close to releasing version 1.0

I was playing around with WP but couldn’t find a place to put the tracker code without the blog breaking like others have said. If anyone has got it working with WP please let me know where you placed the code.

Other than the problems with WordPress I have not found any other errors, and none have been reported.

Posted on Mar 30, '07 at 06:18 am

I’m still getting the error, no matter where I place the code. The error seems to reference part of mints pepper API that’s trying to log an error note. In particular, this line.

$this->Mint->logErrorNote('<p>Mint has detected the unlicensed use of the Mint 2 Pepper class on a '.$this->Mint->getFormattedVersion().' installation. Mint 2 is a paid upgrade. Please login into the <a href="http://www.haveamint.com/account/">Mint Account Center</a> and upgrade the license for this domain.</p>');

I’m really not sure where to go with this, no other pepper seems to exhibit this, not even Birdfeeder which uses a similar approach to this.


I’m unable to get this to work with WordPress as well. I’ve tried several different locations to see if there was a difference - and nothing appears to work.

Please let us know when there’s a solution for WordPress? Thanks.

Posted on Apr 02, '07 at 05:13 pm

I’ve fixed the problem with WordPress and have tested it myself. It seems to be working flawlessly with WP now.

I’ll be releasing a new version which includes the WP fix as well as several other fixes soon.

Posted on Apr 02, '07 at 07:05 pm

mls, may I ask what the fix entailed?

Posted on Apr 02, '07 at 08:21 pm

Whatever the fix might have been, mls, thanks for taking the time to track the problem down. I look forward to reinstalling Crawlers on my site.

You must be logged in to reply. Login above or create an account

Hey there, I have officially suspended sales and support of Mint. The Create Account, Add License, Transfer License, and Contact forms have been disabled. Existing customers may continue to login and download Mint.

More info Continue