Login to download the latest version of Mint and your favorite Pepper, purchase additional licenses, or post in the Forum. Don't have an account? Create one!

In Partnership with Media Temple

Mint Forum

Upcoming: WordPress Bird Feeder Plugin

Ronald Heft
Third-Party Pepper Developer
Posted on Jan 29, '07 at 03:40 pm

Just a heads up Mint users. I have a WordPress plugin which will automatically include all the necessary code for Bird Feeder in your feeds. At the moment my portion of the code is working, however Bird Feeder doesn’t seem to be functioning. As soon as I can get Bird Feeder working for me and do some final tests, I’ll release the plugin.

BOK
Minted
Posted on Jan 29, '07 at 04:44 pm

Cool! I was actually waiting for this… and in the meantime I’ve set the birdfeeder directory to 600 and owned by root, so Mint v2 won’t be able to see it. ;-) As said: I’ll be waiting!

Excellent stuff, I was hoping someone would do it.

Awesome!! Very much looking forward to this, thank you! :)

Ronald Heft
Third-Party Pepper Developer
Posted on Jan 29, '07 at 06:41 pm

Just to note, if anyone knows how to fix the bug outlined in this thread, let me know ASAP. This is what’s holding me up from releasing the plugin. http://haveamint.com/forum/troubleshoot … ird_feeder

Cool.

Ronald Heft
Third-Party Pepper Developer
Posted on Jan 31, '07 at 01:39 am

A quick update. This plugin is on hold for the time being. While I technically have it working and ready to use, an issue with Bird Feeder and WordPress prevents this from being of any use to anyone. Once the Bird Feeder / WordPress issue is resolved, expect this plugin shortly after.

So in the meantime I’m expected to hardcode my own files? I just got noticeably sadder, it’s not that I can’t do add the lines myself, it just seems like the kind of thing a plugin is for. Oh well, if it’s not ready, it’s not ready, I just want you to know that I appreciate your efforts.

Ronald Heft
Third-Party Pepper Developer
Posted on Jan 31, '07 at 08:17 am

No, I’m not saying to hard code the files, because if you do you’ll run into the same problem as I am with WordPress. For the moment, Bird Feeder isn’t compatible with WordPress if you run any plugins that do anything to your feed. That goes if you install Bird Feeder by plugin or doing it yourself. As soon as this issue is resolved, I will release this plugin.

Thank you Cavemonkey. Im looking forward to your plugin

kristin
Minted
Posted on Feb 02, '07 at 08:28 pm

Thats bad info. I’m having no problem with birdfeeder and wordpress. If you need help you can download my versions of the feed files here: wiphey.com/2007/02/02/quick-setup-birdf … wordpress2

Ronald Heft
Third-Party Pepper Developer
Posted on Feb 08, '07 at 05:08 pm

kristin, it’s not bad info. If you had any plugins which modified your feed, Bird Feeder conflicted. You were most likely able to get it to work since nothing was touching your feed. I wasn’t in the mood to deal with all the support request which would certainly pile in, so I figured it would be best to wait for an official solution.

Shaun has figured out the issue and now adding one extra line of code corrects the problem for all. In the time that I’ve waited, I’ve been beat to a plugin release. That’s fine by me. I now recommend you use this plugin.

The plugin still hasn’t been updated to work with Shaun’s fix, but it should be shortly. I’ve also sent him some changes which will hopefully make it better for all. If you’re looking for my plugin, just use that one now.

junomat
Minted
Posted on Feb 26, '07 at 02:48 pm

After activating this plugin my RSS basically dies. Has this happened to anyone else and is there a fix?

Thanks.

Just a little note on my experience getting this plugin to work (WP 2.1 and 2.1.1; Bird Feeder 2.02; WP plugin version 0.8). I had a similar problem to junomat’s.

My feeds were completely empty after activating the plugin. So, I started to deactivate other plugins one-by-one. Turns out that there is a conflict with FAlbum. I was using FAlbum 0.6.7, so I upgraded to 0.6.9 but that didn’t help.

I poked around in the FAlbum options to see if there was any quick fix, and I gave a shot at setting “Enable globally” to false. That worked.

Hope it helps somebody.

I’ve also noticed problems with a few other plugins.

Short list that I’ve just quickly went through on my own: Google Analytics 0.51v, Markdown 1.0.1c, WP-Cron 1.3, WordPress Database Backup 1.7.

Rockstarmark, upgrade the database backup plugin to 2.0: ilfilosofo.com/blog/wp-db-backup

No problems here on WordPress 2.1. Thanks!

Muskie
Minted
Posted on Apr 26, '07 at 09:41 pm

I still can’t get Feeds or Seeds to work. I have just upgraded to the latest version of Mint and the latest version of this WordPress plugin. Is there code I need to add or remove from my WordPress theme or installation?

I have mint installed at domain.ca/mint and my blog at blog.domain.ca/

The blog subdomain is a directory on the same level as the mint directory, if that means anything.

Muskie
Minted
Posted on Apr 26, '07 at 09:49 pm

I had WP-Cron installed but I deactivated it now, that doesn’t seem to make a difference. I don’t think I’m actively using WP-Cron. I have Ultimate Google Analytics, but I don’t really need that either, I’ve been thinking of getting rid of Google Analytics and just having Mint and what my webhost provides.

I can’t recall when I last looked at my Google Analytics stats.

Ronald Heft
Third-Party Pepper Developer
Posted on Apr 27, '07 at 02:18 am

Hey guys, sorry to hear you’re having problems. As I mentioned early in this thread, I was beat to the plugin release and the plugin currently out there is not mine.

I don’t think the author of the plugin checks the Mint forums. If you need help, drop me an email and I’ll get you in contact with him.

You must be logged in to reply. Login above or create an account

Hey there, I have officially suspended sales and support of Mint. The Create Account, Add License, Transfer License, and Contact forms have been disabled. Existing customers may continue to login and download Mint.

More info Continue