Login to download the latest version of Mint and your favorite Pepper, purchase additional licenses, or post in the Forum. Don't have an account? Create one!

In Partnership with Media Temple

Mint Forum

Odd Behavior - some peppers ok, others missing data

Posted on Oct 30, '07 at 12:02 pm

Our dedicated server crashed yesterday and we’re still trying to figure out what caused it. Disabling mod-gzip finally got us up and running again.

In the meantime, I noticed that when MINT 2.12 came back up, it showed the complete and updated Visits, Referrers, Trends Internals and Outbound Links peppers — but Pages, User Agents, Crushes, Searches and Local Searches only show their Titles and Tabs but no data.

What might cause those to not work while the others continue to function normally?

Shaun Inman
Mint/Pepper Developer
Posted on Oct 30, '07 at 01:01 pm

Sounds like your mint_visit table might have crashed. If that’s the case try doing a REPAIR TABLE on it using a tool like PhpMyAdmin (or the SQL command line if you prefer).

Posted on Oct 30, '07 at 04:55 pm

I first tried to access phpmyadmin from cPanel for the account where Mint is located but I got an error saying there was no space left on the device. I determined that the error message was false but obviously something else is the problem. I then moved into WHM and ran phpmyadmin from there. No errors and eveything looked ok but I ran repair anyway.

twoway_Mint.mint_visit repair status OK

I then logged out of Mint and back in but the problem remains.

4 peppers work, 5 peppers don’t.

I’ve seen a few other anomalies. Part of a php script for an ecommerce program fails on the same site as Mint, though both the main ecommerce site and php script work. WHM reports an error for a plug-in stating that the ionCube PHP Loader needs to be installed. Worked fine before our crash.

Could the failure of the five peppers be related to PHP in any direct way?

Shaun Inman
Mint/Pepper Developer
Posted on Oct 31, '07 at 10:26 am

Sure, since Mint relies on PHP, if PHP isn’t working correctly that could be the source of the problem.

Posted on Oct 31, '07 at 10:40 am

My confusion stems from the fact that four peppers work and five peppers don’t. I would assume a problem with PHP would derail everything.

I’m waiting on my ISP to finish diagnostic tests to see if they can locate a problem. Phpmyadmin and a troubleshooting script I ran have not revealed anything obvious.

Here’s a funny:

A few weeks ago I posted here about a problem where Mint and Google Analytics, which had been in close sync for months, suddenly diverged, with Mint underreporting. The Mint debugger showed the errors but no one had a solution.

Since the server crash Monday afternoon and the pepper problem, the errors still show up in the debugger but now only occasionally, and for the first time in weeks the stats yesterday were within 3% of Google’s (they had been 15-25% less).

Posted on Nov 01, '07 at 11:27 am

Problem solved.

When my server crashed a few days ago, my ISP support people said they thought mod_gzip had caused the crash and disabled it. Indeed it may have contributed to the crash because it dumped huge .wrk files into the /tmp directories, filling them up to their capacity.

Once I deleted the .wrk files, all the wackiness in PHP, Mint and other scripts went away.

All is back to normal.

Note that I got a few PHP errors informing me that I was out of disk space. I checked my server’s hard disk, and it had plenty of room so I thought the error messages were bogus. What I forgot to check were the /tmp directories in the /var and /usr directories which are set to specific capacities.

I’m becoming a de facto webmaster.

You must be logged in to reply. Login above or create an account

Hey there, I have officially suspended sales and support of Mint. The Create Account, Add License, Transfer License, and Contact forms have been disabled. Existing customers may continue to login and download Mint.

More info Continue