Login to download the latest version of Mint and your favorite Pepper, purchase additional licenses, or post in the Forum. Don't have an account? Create one!

In Partnership with Media Temple

Mint Forum

Mint on iPhone Doesn't Load

alt text

Recently the iPhone pepper seems to not be loading.

Shaun Inman
Mint/Pepper Developer
Posted on Aug 13, '09 at 09:32 am

Is this just happening in the iPhone Pepper or is the desktop version exhibiting this problem too? Have you tried adding ?errors to the Mint url to turn on PHP error reporting? If not, do so and report back any errors you find.

im not sure if my problem is the exact same as the OP, but its close enough that i figured rather then start a new thread.. id play add-on.

Mint when viewed from the web interface is working perfectly, but when i view Mint from my phone the page loads, all the panes load.. but there is no data being displayed in any of them.

I am not sure if this is a css thing, or a db thing.. actually now that im thinking bout it i am doing to spoof the iphone browser in firefox and test it out..

but while i am doing that, any other suggestions? oh and yes it was working at one point.


ok quick update.

Spoofing iphone3.0 browser showed all the stats and panels just fine. I did notice two things though when comparing.

The list of panels i have activated at the top turned into a dropdown menu on the spoofed brower version, while it remains a horizontal list of links on my actually phone.

The other thing, is that none of the panel links, when clicking on them, do anything. Just sends me to teh top of the page.. maybe empty # href’s, so im guessing some javascript or something didnt load.

any suggestions?

Shaun Inman
Mint/Pepper Developer
Posted on Feb 22, '10 at 09:35 am

Panes collapse into a dropdown when screen real estate is at a premium (not the case when you’re spoofing in Safari). Go into your Safari settings on the iPhone and turn on the Debug Console (Settings > Safari > Developer). That should tell you if there are any missing files of JavaScript errors.

Problem solved..

I went to flip the Debug Console on and noticed that JavaScript had been turned off.

Thats just about on par with forgetting to plug in the computer….


i’m not sure if my situation is the same as everyone but i have recently created a new mint installation.

mint works fine on the ipad and any desktop browser but it does not work on the iphone. the web interface will load on my phone showing me the various peppers but when i go to expand that pepper’s data, i’m presented with a username password interface and then i’m kicked out of the installation.

does anyone know why this is happening?

never mind, my cookies were disabled on the browser. solved..

You must be logged in to reply. Login above or create an account

Hey there, I have officially suspended sales and support of Mint. The Create Account, Add License, Transfer License, and Contact forms have been disabled. Existing customers may continue to login and download Mint.

More info Continue