Login to download the latest version of Mint and your favorite Pepper, purchase additional licenses, or post in the Forum. Don't have an account? Create one!

In Partnership with Media Temple

Mint Forum

New installation: Logging in, then instant redirect to login page

Hi, I installed Mint (my 3rd installation since 2005), after logging in the page jumps back to the login-screen. While trying to load the Mint statistics (before getting redirected back to login), there’s a strange content showing up, maybe this could help in troubleshooting.

short view after logging in

Thanks in advance!

Regards, Achim

Shaun Inman
Mint/Pepper Developer
Posted on Nov 01, '09 at 11:10 pm

This is probably a cookie conflict. Try manually deleting all Mint cookies set by your domain (including but not limited to www.domain.com, domain.com and .domain.com—note the leading period).

Thanks for your answer!

I tried to clean all cookies as you said, I did also try a never-used browser (Opera Mac) and also my Firefox.app fails in the same way.

I use a Serendipity installation with a separate DB for Mint. Should I switch from MySQL 5.x to MySQL 4.x? I don’t think that this is the issue … please help, thanks much.

For more details, please ask.

Shaun Inman
Mint/Pepper Developer
Posted on Nov 05, '09 at 04:10 pm

This has nothing to do with MySQL. It’s a cookie problem. Perhaps your server’s time is incorrect and setting cookies in the future, past the expiration date which is causing them to expire immediately.

the server time is right:

Server Apache/1.3 Scripting Language PHP/5.2.8 Server Time Fri, 06 Nov 2009 11:08:49 GMT

(this is nearly now …)

what about denying cookies? other ideas?

my other trials:

  • using a freshly installed IE8 on a XP Virtual machine = same fail
  • disabling all htaccess direction on web server = no success

we should start thinking about a refund if we don’t find a server-based bug — it’s a bread and butter LAMP server that fully meets Mint’s requirements

I’d like more to get Mint running, ‘cause I love its realime stats :-)

Shaun Inman
Mint/Pepper Developer
Posted on Nov 06, '09 at 10:23 am

Shoot me an email (using the contact form in the footer of this site) with the url of your problem Mint installation, and if possible, the email/password (I’d normally suggest you change it to something you are comfortable sharing but if you keep getting booted out you probably can’t change that) so I can take a look.

Posted on May 11, '10 at 06:21 pm

i am actually having the same problem - we have a dozen mint installes never seen this but on a new domain with the latest release its happening… login logs me in then boots me back out…

Posted on Jun 12, '10 at 02:20 pm

I’ve got exactly the same problem, has anybody found a solution?

It works locally, but on our internal server it doesn’t

Posted on Jun 13, '10 at 05:22 pm

I have noticed the same problem when Mint is installed both on a main domain and a subdomain. I can only stay logged in to the Mint installation on either the main domain or the subdomain, never both.

Shaun Inman
Mint/Pepper Developer
Posted on Jul 06, '10 at 08:21 am

If you’re getting booted there’s a very good chance that you have two or more conflicting login cookies. Delete any and all “MintAuth” cookies and try logging in again.

Posted on Jul 06, '10 at 04:33 pm

Thanks for responding!

No luck, unfortunately.

I cleared the cookies, successfully logged into the Mint installation on the main domain, and set the “Ignore my visits (uses cookies)” option. I was then able to login to the Mint installation at the subdomain, but I was immediately booted back to the login screen once Mint finished loading.

If I logout or clear cookies from Mint at the main domain, I can then use Mint at the subdomain without any problems, but it looks like I can’t be logged into both at the same time.

I tested this in both Safari 5.0 and Firefox 3.6.6.

Posted on Jun 26, '11 at 12:01 pm

Now I’m having that too (after so many Mint installs on a variety of servers). Checked/Cleared my cookies, tried different browsers, no success.

Has anybody found a solution to this issue?

Posted on Jun 26, '11 at 12:37 pm

In my case I could fix it by deleting all peppers and reinstalling them one by one. Probably one of the files was corrupt when uploading it the first time. Strange, but such things can happen.

Posted on Jun 26, '11 at 12:41 pm

OK, I tracked this further down. While uploading a BOM was added to one of the files - strange behaviour by my FTP client.

I edited the file on the server (with my FTP client) and then I saw the three BOM characters . Just deleted them and everything worked.

You must be logged in to reply. Login above or create an account

Hey there, I have officially suspended sales and support of Mint. The Create Account, Add License, Transfer License, and Contact forms have been disabled. Existing customers may continue to login and download Mint.

More info Continue