Login to download the latest version of Mint and your favorite Pepper, purchase additional licenses, or post in the Forum. Don't have an account? Create one!

In Partnership with Media Temple

Mint Forum

Changed website, htaccess was causing a problem

I used to have Mint working fine with my Wordpress website.

I simply added the javascript line into my template header, and all seemed to work well.

I have now moved to a more basic website, still loading mint by just adding the javascript line to each page. I have a .htaccess file (in web root) with the following:

RewriteRule ^([^/\.]+)/?$ index.php?p=$1 [NC]

This was causing issues with viewing mint, so my solution was to add a .htaccess file in /mint/, with the line

RewriteEngine off

This has fixed the issue.

The purpose of this post is to see if this is the correct thing to do, or am I forgetting something?

(I have checked, and /mint/?js still loads the javascript just fine.)


Shaun Inman
Mint/Pepper Developer
Posted on Dec 28, '09 at 08:40 am

This is the correct solution. If you introduce a rule that breaks Mint, disabling that rule or the RewriteEngine entirely for your Mint directory is the correct way to fix it.

Thanks for the confirmation.

Posted on Nov 08, '11 at 11:45 am

Thanks for this, I was having issues with a WordPress security plugin (BulletProof Security) disabling my stats from tracking and adding an .htaccess file with that rule solved the problem instantly.

This was a fix for me as well. By disabling the ‘Better WP Security’ section of the root .htaccess mint started tracking. Reenabling it broke mint. Adding this separate .htaccess to the root of the /mint/ folder fixed it.

You must be logged in to reply. Login above or create an account

Hey there, I have officially suspended sales and support of Mint. The Create Account, Add License, Transfer License, and Contact forms have been disabled. Existing customers may continue to login and download Mint.

More info Continue