Login to download the latest version of Mint and your favorite Pepper, purchase additional licenses, or post in the Forum. Don't have an account? Create one!

In Partnership with Media Temple

Mint Forum

Mint preferences not loading fully

I tried to install Mint 3 times, and after I am done the preferences do not load fully. You can access it at collaborativeinnovation.org/mint/mint%20screenshot.png to see a screenshot of what I mean. I have it set up on multiple other sites without any problems.


Did I not phrase my issue correctly so that nobody can help?

I can’t help you, but I’ve got exactly the issue. It happened after an upgrade a couple of years ago; subsequent upgrades haven’t helped. I haven’t tried a reinstall.

I just upgraded to Mint 2.19 and am having the same issue.

I’m having this issue too. No one seems interested in debugging it, so I’m uninstalling Mint and switching to Google Analytics.


A little help Shaun?

Posted on Jan 04, '12 at 02:56 pm

i too have no loading prefrences panes

Shaun Inman
Mint/Pepper Developer
Posted on Feb 09, '12 at 07:38 am

Thanks for bringing this to my attention Donald. For everyone’s future reference: this Forum is community supported. If you don’t find an answer, please, use the contact form. I’m happy to help.

This problem is frequently the result of having a duplicate Pepper in your /pepper/ directory. If you add &errors to your Preferences url and reload you should see an error (something along the lines of “Fatal error: Cannot redeclare…” followed by the name of the duplicate file). Remove that file and the Preferences should load again.

I just ran into this too. In my case the &errors addition to the URL didn’t help, so I had to start hacking around in /pepper hoping to find a clue.

It turned out the problem for me was a residual unzipped “default_v209” folder that I had left at “/peppper/default_v209” while upgrading in the past. (As a peer to e.g. “shauninman” namespaced folder.

Will take care to keep that folder more tidy in the future!

(Update: turns out my errors not showing was specifically because I’ve configured my site to log PHP errors instead of showing them. Duh!)

You must be logged in to reply. Login above or create an account

Hey there, I have officially suspended sales and support of Mint. The Create Account, Add License, Transfer License, and Contact forms have been disabled. Existing customers may continue to login and download Mint.

More info Continue