Login to download the latest version of Mint and your favorite Pepper, purchase additional licenses, or post in the Forum. Don't have an account? Create one!

In Partnership with Media Temple

Mint Forum

Secret Crush name issue (with Textpattern)

I’ve reviewed this thread in which people appear to be having similar issues to mine, but it also looks like they were all solved with Secret Crush 2.06 (which I am running).

My Secret Crush Pepper does not seem to be tracking names either. When I choose to track names only, I get values like “375,474,198”, “-2089726019” and “1,575,247,936”. “375,474,198” is, apparently, me, though the name I put in when I posted a comment was “Kyle” (also the value stored in the cookie txp_name). The cookie is set to .digitalovertone.com, and the site URL in my Textpattern setup is digitalovertone.com.

If anything other than “Name only - ignore unnamed” is selected, the pepper appears to work flawlessly. My ideal setup - Name/Hostname/IP Address - jumps directly to Hostname without displaying any strange integers as names.

Any thoughts? Any Textpattern users having similar issues? Are any successfully using this pepper?

My Mint installation is http://digitalovertone.com/mint

Sam Brown
Third-Party Pepper Developer
Posted on Mar 27, '07 at 10:14 am

bump

I am actually having the exact same issue. Was about to post a new thread but my problem is exactly the same however I do not get any strange integers as names.

My textpattern folder is located at massiveblue.net/pepperminttea/textpattern/.

Cookie are set for massiveblue.net and as Kyle mentioned above, the cookie name is txp_name.

When set to “Name only - ignore unnamed” secret crushes displays nothing. However, when set to “Name/Hostname/IP Address” it displays correctly, except no Name, just Hostname & IP.

Edit

Could this have something to do with Secret Crush not being able to read the cookies like mentioned in the README.txt file in regards to WordPress?

Shaun Inman
Mint/Pepper Developer
Posted on Mar 27, '07 at 10:28 am

Could this have something to do with Secret Crush not being able to read the cookies like mentioned in the README.txt file in regards to WordPress?

It would appear so. I do not see my TXP cookies in the global $_COOKIE array in your #Mint:Debug output.

ramanan
Minted
Posted on Mar 27, '07 at 12:06 pm

Strange because I have two textpattern installs on my domain, one at /textpattern/, one at /shima.mirkarimi/textpattern/ and both work with Secret Crush just fine.

Sam Brown
Third-Party Pepper Developer
Posted on Mar 28, '07 at 05:29 am

Which is the preferred location for the cookie to be saved?

domain.com or .domain.com ? (Notice the period in example 2.)

Shaun Inman
Mint/Pepper Developer
Posted on Mar 28, '07 at 09:14 am

With the dot. That will ensure that both domain.com and *sub.domain.com can access the cookie. (But it won’t update the existing cookies of visitors who have already left a comment and been cookied with the previous setting.)

Sam Brown
Third-Party Pepper Developer
Posted on Mar 28, '07 at 12:06 pm

Right. My textpattern installation is saving cookies without the period in front of the domain.

Rachel
Minted
Posted on Jul 26, '07 at 11:02 pm

I’m having this problem as well. You’ll have to forgive me, but I can’t figure out what exactly the solution is from reading this thread — can someone spell it out for me?

Sam Brown
Third-Party Pepper Developer
Posted on Jul 27, '07 at 03:51 am

Basically I think we need to edit the cookie saving in Textpattern from domain.com to .domain.com.

After that is done, anyone from that point forward will be seen in Secret Crush (everyone else who has already posted a comment is cookied with the old cookie).

That said, Ramanan seems to be having no problems at all.. so I really am not sure what to do.

Rachel
Minted
Posted on Jul 27, '07 at 03:46 pm

Okay, that’s what I suspected… so, how exactly do I edit the cookie saving? There doesn’t seem to be anything in the Txp control panel. Do I have to mess around with the source code?

Sam Brown
Third-Party Pepper Developer
Posted on Jul 27, '07 at 04:04 pm

Yep, I’m afraid so.. I haven’t even looked into it yet, perhaps a post at the Textpattern Forums may be in order.

Rachel
Minted
Posted on Jul 27, '07 at 04:17 pm

Hm. I feared as much.

Something strange, though — when I go to Preferences and select “Name only - ignore unnamed”, there is one name that shows up for a visitor who stopped by last week (and, as expected, all the other IPs that showed up before are now ignored). Wouldn’t that suggest that the problem isn’t with the cookie setting, if one cookie managed to be read correctly?

You must be logged in to reply. Login above or create an account

Hey there, I have officially suspended sales and support of Mint. The Create Account, Add License, Transfer License, and Contact forms have been disabled. Existing customers may continue to login and download Mint.

More info Continue