Login to download the latest version of Mint and your favorite Pepper, purchase additional licenses, or post in the Forum. Don't have an account? Create one!

In Partnership with Media Temple

Mint Forum

Bird Feeder and WordPress

MacManX
Minted
Posted on Feb 24, '07 at 01:24 am

I had the same problem when I activated Bird Feeder for the first time. At the time, I was more concerned about trying the plugin again without Seed functionality, so I didn’t pay much notice to it. Unfortunately, activating Bird Feeder a second time resulted in the disappearance of the User Agent 007 pane. After a brief search through the forums, I found Shaun’s rebuild-panes script which restored User Agent 007 along with the missing “Readers” tab.

You’re not exactly in the same situation as I was, but you may want to try the script just to see if it fixes the problem, and please make a backup of your Mint database before using the script.

I found that I had to uncheck the setting in Preferences, click Done, go back to Preferences, toggle the setting again, and then the Readers tab showed up again.

Any progress on this? Whether I install the wp-plugin or directly edit the feed files, my feeds stop working.

Muskie
Minted
Posted on Mar 10, '07 at 04:04 pm

I upgraded to WordPress 2.1.2 I’d never bothered to upgrade to 2.1.1, then I upgraded Mint and all it’s plugins. My blog is working as well as it was before 2.1.2 but I still think it worked better in 2.0….

I installed the WordPress BirdFeeder plugin but still have zero data being collected in Mint. I tried subscribing to my own blog even and that didn’t go so well.

I clicked the feed icon in the address box in Opera and it didn’t seem to do much so I scrolled down to the bottom and tried to subscribe in my footer, this launched Safari but also didn’t work. I have no idea why Safari launches sometimes when I subscribe to a feed in Opera, but not other times…

I pruned a lot of WordPress Plugins a few weeks back prior to Web Directions North, I don’t have any that modify my feeds prior to the BirdFeeder Plugin, I don’t even use FeedBurner.

Any ideas my blog url is: blog.muschamp.ca

I’ve never had BirdFeeder working, all my other Mint and WordPress plugins initially seem fine.

MacManX
Minted
Posted on Mar 19, '07 at 04:27 pm

I think I’m having the same problem as Muskie, or something related.

I didn’t use the WordPress Bird Feed plugin, but I did add the proper PHP code block to the top of the feed files. This worked perfectly under WordPress 2.0.9.

I just upgraded to WordPress 2.1.2, and no matter where I put the PHP code block, the feeds appear blank and are not valid. They function properly when the PHP code block is removed.

stickel
Minted
Posted on Mar 29, '07 at 11:32 am

As annoying as it is being another “me too” poster, I’m having the same issue as Muskie and MacManX. I just upgraded to WP 2.1.2 and when the BirdFeeder pepper is installed my feeds are broken.

More specifically, I’ve found that the feeds work as long as the $wpdb->select(DB_NAME) is commented out. In my case that seems to be the offending line of code breaking the feed.

For the time being I think I’ll just downgrade to WP 2.1

stickel
Minted
Posted on Mar 29, '07 at 11:58 am

Correction from my last. It now seems to be the <?php $BirdFeeder->seed(the_title_rss(), permalink_single_rss()); ?> inside the <item> tags on the feed that cause the issues for me. When commenting that line out while leaving all the others visible the feed works but as soon as I uncomment that line/code the feed breaks again.

Shaun Inman
Mint/Pepper Developer
Posted on Mar 29, '07 at 12:24 pm

Unfortunately Iím not running MySQL 4 so I canít test WP 2.1.x. Have you asked around the WP boards? Perhaps they would have a better idea of what changed between the two versions that might have introduced this conflict.

Shaun Inman
Mint/Pepper Developer
Posted on Mar 29, '07 at 12:50 pm

I just installed a local copy of MySQL 4 and Wordpress/Mint/Bird Feeder. Adding:

global $Mint;
define('BIRDFEED', 'Feed Name');
include($_SERVER['DOCUMENT_ROOT'].'/feeder/index.php');

Before:

if (empty($wp)) {
    require_once('wp-config.php');
    wp('feed=rss2');
}

(in all the respective feed format files, eg. wp-rss2.php) seemed to do the trick for me.

stickel
Minted
Posted on Mar 29, '07 at 06:35 pm

Nevermind, user error. Too much code viewing lately. I was using the the_title_rss instead of get_the_title in the link. deeeerrrrrr….. ;^)

I tried running the plugin in WordPress MU as a mu-plugin and it distorts my feeds with database errors as well.

Warning: Missing argument 2 for wpdb::select(), called in /xxx/stefan/wp.devilicious.net/wp-content/mu-plugins/MintBirdFeeder.php on line 32 and defined in /xxx/stefan/wp.devilicious.net/wp-includes/wp-db.php on line 91

Warning: Cannot modify header information - headers already sent by (output started at /xxx/stefan/wp.devilicious.net/wp-includes/wp-db.php:91) in /xxx/stefan/wp.devilicious.net/wp-includes/wp-db.php on line 438

WordPress

Canít select database

Running it as a single plugin in WPMU does the same. Any idea on how to fix this?

I would also like to see it running on MU. I have a wordpress blog that are set-up as MU, but I just can’t find a way to track it with bird feeder.

Any ideas?

This plug in for Wordpress is working for me properly on 2.9.1 http://forgecode.net/2010/01/a-wordpres … ird-feeder

You must be logged in to reply. Login above or create an account

Hey there, I have officially suspended sales and support of Mint. The Create Account, Add License, Transfer License, and Contact forms have been disabled. Existing customers may continue to login and download Mint.

More info Continue