Login to download the latest version of Mint and your favorite Pepper, purchase additional licenses, or post in the Forum. Don't have an account? Create one!

In Partnership with Media Temple

Mint Forum

Mint installation showing %3 and %3a in referrers url

Hi guys,

My mint installation is showing unusable urls in the referrers panel.

Ex: http%3A//leevigraham.com/mint/%3Fpreferences

Any ideas?

Sam Brown
Third-Party Pepper Developer
Posted on Jul 04, '07 at 05:20 am

Search.

Solution.

I’m sorry Sam, but I’ve implemented the solution but it still does not work.

Sam Brown
Third-Party Pepper Developer
Posted on Jul 06, '07 at 06:00 am

Strange, sorry my solution didn’t work.

Hopefully Shaun can help you out with this.

Shaun Inman
Mint/Pepper Developer
Posted on Jul 06, '07 at 08:46 am

This solution will not affect previously recorded hits. If you look at one of the “Most Recent” tabs, does Mint still exhibit this problem?

flowsa
Minted
Posted on Jul 09, '07 at 10:32 am

Hi

I’m also having problems with this and

RewriteEngine off

Does not work.

I’m using mod rewrite to perform 301 redirects from other web domains to my primary web domain, which has mint installed on it.

The primary web domain has no mod rewrite on it itself, but even if I add the above to the htaccess, it does not change the situation

I get %3a and %20.

Please help!

Hello,

I JUST noticed this occurring on my Mint install.

What I didn’t attribute it to was that yesterday I made changes to my main .htaccess file to rewrite the domain so that “www.” wasn’t included anymore.

I simply went into my Mint preferences and noticed that for the Mint location it still had “http://www.domain.com/mint” all I did, was remove the “www.” and its now showing normal links, no more “%3A” “%20” etc.

HOWEVER, it didn’t fix previous entries, it’s only now correctly displaying new entries.

Just thought I would post that, might help you.

Sidenote: Now that I’ve done this, “Check for updates” isn’t working, because the URL string it passes to the mint website is still “www.domain.com/mint” instead of “domain.com/mint”. - Any ideas?

Shaun Inman
Mint/Pepper Developer
Posted on Jul 10, '07 at 10:21 am

Try using the ?moved query command on your Mint installation.

You can then also run a couple of quick sql ommands to update your database:

sql = “update mint_visit set resource_title = replace(resource_title,’%3A’,’:’)”;

This replaces all ‘%3A’ in the resource_title field with a ‘:’

You will find that you need o do this a couple of times in different fields.

Oh and BackUp your database.

flowsa
Minted
Posted on Oct 01, '07 at 05:53 am

I’m having the same problem which appeared out of the blue and I’m getting no proper referrer data at all.

I’ve tried the above, nothing works. All my new unique referrers are existing pages on my website pointing to one another. Really strange.

Links look like this: http%3A//www.google.com…

and link to: domain.com/mint/http%3A//www.google.com

Shaun Inman
Mint/Pepper Developer
Posted on Oct 01, '07 at 10:43 am

flowsa, which domain are you seeing the problem on?

Hey there,

I have the same issue, but need RewriteEngine to be on. To me the same happens, which happens to flowsa:

https%3A//www.google.com

leading to:
https://beyondtellerrand.com/mint/https … google.com

Any help to solve this?

Thanks a lot.

/marc

You must be logged in to reply. Login above or create an account

Hey there, I have officially suspended sales and support of Mint. The Create Account, Add License, Transfer License, and Contact forms have been disabled. Existing customers may continue to login and download Mint.

More info Continue